Tuesday, July 7, 2009

Dell Wireless 5600 (EVDO-HSPA) Mobile Broadband Mini-Card & Windows 7

Status: Still not working.

I had a heck of a time getting this "Dell Wireless 5600 (EVDO-HSPA) Mobile Broadband Mini-Card" mini pci cdma card working with Windows 7 and my E6400. The drivers are contained in the Control Point Connection Manager package. Here's the current version at this time.

Install the package. The drivers still won't be installed at this point, though. Open the Computer Management panel, go to the drivers and update the driver for the card. You need to "browse manually" for the driver and point it at
C:\dell\drivers\R218755\Qualcomm\Drivers\Source\Module Retargetable Folder\QCUSB-Dell\DriverPackage\Qualcomm\Win64\AMD64


If you point it at a higher folder and tell it to search sub folders it will try to install the wrong driver.

At this point the drivers are installed but the control point connection manager still does not see the device. I also tried the Verizon VZAccess app with no luck. If anyone knows how to make this work please let me know.

18 comments:

Anonymous said...

install the 5530 driver package in addition to the 5600 drivers. this will allow control point to manage the 5600 card. I stumbled onto this when my 5600 card under W7 RTM stopped working after uninstalling the driver package for the 5530 card i used to have.

hope this helps

Mondo said...

Allegedly they've updated the Vista x64 drivers and those do work, but I haven't tested them yet. Thanks for the info, though!

David S. said...

I am trying to do the same thing with a E6500 - and running into the same problem. At one point I got Connection Manager to recognize the device, but it had the wrong firmware loaded. The button to change the carrier was greyed out, so I couldn't change it. When I tried to uninstall and reinstall, Connection Manager no longer saw the card - and hasn't since. I can't figure out what I did to get it to see the card to start with. I continue to scan the net looking for information, but have found nothing yet. If anyone gets this to work, I'd love to know how. I'll coma back and share anything I find.

Regards - David S.

Anonymous said...

Anyone ever find a solution to this??

Marlon said...
This comment has been removed by the author.
Marlon said...

David S,

To get the GOBI Card working on the e-6500.. Do the following..

1. Do not install any version of connection manager, especially the one for the e6500. It will leave left over files that will not allow the card to function properly, even after uninstalling it
For the 32bit Driver, use the file Labeled "DELL_CONTROLPOINT-CONNECTION_A15_R218754.exe"
For the 64bit Driver, use the file Labeled "DELL_CONTROLPOINT-CONNECTION_A15_R218755.exe"

*I wasn't able to find these from Dell's website, but google saves lives.

Once this is installed you will need to get the Firmware Images... If you look on the e-6500 Download Category Labeled "Communication", it's the file labeled as the following:

"Dell - Firmware Wireless 5600 (EVDO-HSPA) Mobile Broadband Mini-Card"
Install your remaining drivers as necessary.

-Marlon

That Guy said...

When you say "Do not install any version of the connection manager", you mean any version but the one you talk about in the next line (A15), right?

I have been unabled to get the 5600 working with my E6500 windows 7 install. In connection manager “Mobile Broadband” is greyed out, even though device manager shows it correctly installed (under ports).

I've installed the connection manager you listed, but at first didn't manually install the 5600 driver. I went back after the program install, and installed the driver. Thinking it didn’t find the 5600 when it was first installed (because the driver wasn’t installed), I went ahead and removed Connection Manager. Still, even after reinstalling Connection Manager, "Mobile Broadband" is greyed out.
Any ideas?

Anonymous said...

Correct,

But this method has only been verified to work on Vista Machines, not Windows 7.. If I had a copy of Windows 7, I would get it to work.

Anonymous said...

This seems to be the only post that had relevant info to my problem. Getting this file

*For the 32bit Driver, use the file Labeled "DELL_CONTROLPOINT-CONNECTION_A15_R218754.exe"*

From Dells FTP site and running the full package is what fixed my already activated 5600 Verizon card.

Roman Tumaykin said...

Dell just posted new controlpoint connection manager drivers and utilities for Windows 7. They now support 5600 out of the box - no hack is required.

Chuck said...

Just wanted to say thanks for this. After 2 solid days of searching for and trying different drivers, this article is what got me through an XP install. What terrible software.

Anonymous said...

chuck how were you able to install the 5600 on windows xp?

I have tried Connection Manager A13, A15 and the latest on but I am still showing the "Dell Wireless 5600 (EVDO-HSPA) Mobile Broadband Mini-Card QDLoader"

I have also downloaded the driver only and the firmware - nothing works.

I have installed 5 5600 cards in E6400 and E4300 without any problems until I got this batch this month.

Anonymous said...

The latest connection manager drivers do work on E6500 win7 x64 but one BIG WARNING: DO NOT LET YOUR LAPTOP GO TO SLEEP WHILE CONNECTED!!! Other USB data cards block the PC from going to sleep, the Qualcomm drivers dont.

I did it once, firmware removed, drivers corrupted, uninstall/repair etc unsuccessful. Doing full re-format rebuild tonight to hopefully resurrect my dead 5600 card. If it fails, another rebuild then back to the 5530.

Anonymous said...

I can attest to what Marlon said. These instructions installed the 5600 card on an E6400 running XP perfectly.

1. Do not install any version of connection manager besides one of these:

For the 32bit Driver, use the file Labeled "DELL_CONTROLPOINT-CONNECTION_A15_R218754.exe"
For the 64bit Driver, use the file Labeled "DELL_CONTROLPOINT-CONNECTION_A15_R218755.exe"

You can find them on the Dell FTP site here:
http://ftp.dell.com/Control%20Point/

Once this is installed you will need to get the Firmware Images... If you look on the e-6500 Download Category Labeled "Communication", it's the file labeled as the following:

"Dell - Firmware Wireless 5600 (EVDO-HSPA) Mobile Broadband Mini-Card"

Anonymous said...

Also, I had my card in limbo installing a newer version of the Control Point software and then the firmware. The BIOS saw the card but the Device Manager did not see it at all. I had to pull the CMOS battery as well as the card itself to reset the software. After that, the instructions posted above worked perfectly. This card is kinda crappy.

Anonymous said...

wowow, great blog

jacobsson said...

Mobile broadband business models 3G LTE Networks is changing the face of business. Ericsson created mobile broadband over twenty years ago and since then

Rajmati sah said...

You shared Very valuable and helpful Free Ad Posting .One more very effective Free Ad Posting site where you can Post an Free Ad Posting and sell
Visit Also Here:--
Open ad posting|| Post free ads|| Free Ad Posting